IonCube Loader is a software tool, that's needed to run files that are protected with ionCube PHP Encoder. The aforementioned is an application used to make PHP code human unreadable, so as to protect it from reverse engineering and / or illegal use. Numerous script-driven applications, particularly message boards, content management systems and electronic commerce solutions are encrypted with ionCube PHP Encoder, which means that when you get a script and you notice that ionCube is on the list of website hosting environment prerequisites, you need to make sure that your web hosting server has the tool pre-installed. While it is not that difficult to install it when you have your own server, it is close to impossible to do that on a shared hosting server for the reason that the PHP environment will have to be precompiled and all the clients on the server will be affected.
IonCube in Shared Web Hosting
IonCube Loader is present on all the web servers that are part of our cloud web hosting platform, which means that regardless of the shared web hosting that you choose during the signup process, you'll be able to enable it from your Hepsia Control Panel. The process is as easy as right-clicking an On/Off button from the Advanced section, so even if this is your first website hosting account ever, you will not have to do anything complicated. The same section allows you to select the PHP version for your account (4, 5.2, 5.3, 5.4, 5.5), so in case you would like to switch to another version, you just have to activate ionCube Loader for it too. Due to the fact that our platform is flexible, you may even set some other PHP version and another status of ionCube by using a php.ini file in each domain folder. If this is something you wish to do but you don't have much experience, the 24/7 support team shall assist you very quickly.
IonCube in Semi-dedicated Hosting
As all semi-dedicated server accounts are set up on our advanced cluster platform and ionCube Loader is available on it, you shall be able to use any script app which requires this tool to function properly. With a couple of clicks in your Hepsia hosting Control Panel you will be able to activate or deactivate ionCube for the PHP version that's currently active for the account. Because we support several releases of PHP at the same time, you will need to do that every time you switch to a different version, and if you revert back to a release that you have already used, our system will remember your choice and ionCube Loader will already be activated. If you have a couple of sites in the same account and they require different versions of PHP, you're able to set up a php.ini file in every single domain folder and with several lines of program code you can define both the PHP release as well as the status of ionCube irrespective of what is selected for the hosting account as a whole.